An Example—Eddy Currents

Introduction

To help you understand how to create models using the AC/DC Module, this section
walks through an example in great detail. You can apply these techniques to all the
models in this module, other optional modules, or even the many models that ship
with the base COMSOL Multiphysics package.

The first example model concerns an AC coil surrounding a metal cylinder, and the
coil induces eddy currents in the cylinder. It illustrates how to examine a system using
several different approaches. You can model the coil with or without the skin effect,
and it shows how varying the frequency of the current source also alters the depth of
the skin effect.

Model Definition

To build this model, work with the axisymmetric Azimuthal Induction Currents,
Vector Potential application mode (in the Quasi-Statics, Magnetic folder) in the time-
harmonic formulation. The model represents the cylinder as a rectangle and the coil as
a circle. The modeling plane is the rz-plane; the horizontal axis represents the r-axis,
and the vertical axis represents the z-axis. To obtain the actual 3D geometry, revolve
the 2D geometry about the z-axis.

DOMAIN EQUATIONS
The dependent variable in this application mode is the azimuthal component of
magnetic vector potential, A, which obeys the relation:
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where o is the angular frequency, 6 is the electric conductivity, [ is the permeability, €
is the permittivity, and oJ fo denotes the current density due to an external source. One
way to define the current source is to specify a distributed current density in the right-
hand side of the above equation. This current density gives rise to a current [ as defined
by:

IJe~ds=I
s
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BOUNDARY CONDITIONS

This model requires boundary conditions for the exterior boundary and the symmetry
axis, and to specify boundary currents when applicable. You can apply a condition
corresponding to zero magnetic flux through the exterior boundary by setting the
vector potential to zero. Next, give the symmetry boundary a symmetry condition.
You can also specify the applied current source using equivalent surface currents:

§(nxJS).d1 =1
C

Model Library path: ACDC_Module/Tutorial Models/coil_eddy_currents

The Model Library path shows the location of the Model MPH-file. You can open it
directly from the Model Navigator by clicking the Model Library tab and browsing to
AC/DC Module>Tutorial Models>coil eddy currents.

Coil Without Skin Effect

Begin this study of induced currents by modeling a current-carrying coil without skin
effect.

MODEL NAVIGATOR
I Begin a new COMSOL Multiphysics session by invoking the Model Navigator.

2 On the New page, select Axial symmetry 2D from the Space dimension list.

3 In the list of application modes, click on AC/DC Module, then select Quasi-Statics,
Magnetic>Azimuthal Induction Currents, Vector Potential and finally Time-harmonic

analysis.
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4 Click OK to close the Model Navigator.

Model Navigator 2]

New ‘ Model Library I User Modzls | Open I Settmgsl

Space dimension:

| Application Modes -
[ | COMSOL Multiphysics P
=~ |, AC/DC Module

[ | Statics, Electric
[+ | Statics, Magnetic
B Quasi-Statics, Electric

-+ |, Quasi-Statics, Magnetic A
- % Azimuthal Induction Currents, Vector Poter| =
: # Transient analysis

.

1 # Small-signal analysis

-4 Meridional Induction Currents, Yector Pate

N
Description:

Quasi-statics of conducting, magnetic, and
dielectric materials with electric currents

{14 Meridional Induction Currents, Magnetic Fis Flowing in the angular direction.
[+ | Quasi-Statics, Electromagnetic | |Time-harmonic analysis.
e Virtual Work -

| ([[} | b

Dependent variables:  |Aphi

Application mode name: |emqga

Element: Lagrange - Quadratic - l Multiphysics ]

{ OK ][ Cancel H Help ]

OPTIONS AND SETTINGS

Start the modeling session by adjusting the drawing area to hold the geometry you
plan to draw. Another aid in making the simulation easier is to define variables for later
use when defining the problem.

I Select Axes/Grid Settings from the Options menu to open the Axes/Grid Settings dialog
box.

2 On the Axis page, type -0.05 and 0.5 in the r min and r max edit fields. Then set
the z-axis limits to -0.3 and 0.3.

Axes/Grid Settings &3
[7] Axis equal
r-z limits phi limits
rmin: -0.05 [#] Auto
rmax: 0.5 =
phi min:  |-1
2min:  -0.3 =
phi max: |1
zmax: 0.3
[ [e]4 ] [ Cancel ] [ Apply ] [ Help ]

3 To manually define new grid settings, first click the Grid tab and then clear the Auto
check box.
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4 Type 0.05 in the r spacing edit field and type the value 0.03 in the Extra r edit field.

Set the value in the z spacing edit field to 0. 05 and add two extra grid lines by typing
-0.01 0.01 in the Extra z edit field.

5 Click Apply to see the effects of the new settings. Notice that the interface adjusts

the r-axis settings to maintain the correct aspect ratio. Click OK to close the dialog

box.

6 To define global constants for the model, select Constants from the Options menu.

Doing so opens the Constants dialog box.

7 Enter values in the Name, Expression, and (optionally) Description edit fields

according to the following table:

NAME EXPRESSION DESCRIPTION

sigCoil 0[S/m] Conductivity in coil
sigCyl 3.7e7[S/m] Conductivity in cylinder
I0 1[KkA] Current

diam 2[cm] Coil diameter

circ pi*diam Coil circumference

area pi*(diam/2)"2 Coil area

Jo I0/area Current density in coil
Jso I0/circ Surface current of coil

The numerical values used in the model are now visible in the dialog box.

WP Constants =]

Name Expression Value Description

sigCoil 0[S/m] o[5fm] Conductivity in coil #
sigCyl 3. 7e7[5/m] 3.7e7[5/m] (Conductivity in cylinder B
10 1[kA] 1000[A] Current |
diam 2[cm] 0.02[m] Coil diameter |
circ pi*diam 0.062832[m]  |Coil crcumference TE
area pi*(diam|2)"2 (3.141593e-4)[mCail area |
0 10/arsa 3.183099e6[Ajm Current density in coi

150 10]circ 15915.494309[ASurface current of col

o
=HE ok | [ cancel | [ apply | [ Help
8 Click OK.

GEOMETRY MODELING

Now define the structure’s geometry using the CAD tools built into COMSOL
Multiphysics.
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I Start by drawing a circle that represents the coil. To do so, go to the Draw menu,
point to Draw Objects, and then choose Ellipse/Circle (Centered); alternately, go to the
Draw toolbar on the left of the main drawing area and click the Ellipse/Circle
(Centered) button. Click the right mouse button at (0.05, 0) and move the cursor
to (0.05, 0.01) and then release the button. This action creates the desired circle.

2 Click the Rectangle/Square button on the Draw toolbar or choose the corresponding
entry on the Draw menu (Draw Objects>Rectangle/Square), then using the left mouse

button draw a rectangle with opposite corners at (0, —0.25) and (0.2, 0.25).

3 Choose Draw>Draw Objects>Rectangle/Square once again and create a new rectangle
from (0, —0.05) to (0.03, 0.05). The use of extra grid lines together with the snap
functionality makes this task easier to accomplish.
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4 Double-click GRID in the status bar at the bottom of the window to hide the grid

lines.

PHYSICS SETTINGS

Scalar Variables
I The predefined variables specific to the active application mode are called
application scalar variables. Just as you can do with global variables, you can use

these in any expression for physical quantities, boundary conditions, or
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postprocessing entities. Open the corresponding dialog box by selecting Scalar

Variables from the Physics menu.

Application Scalar Variables P
Name Expression Unik Description
epsilond_emga 5.854187817e-12 Fim Permittivity of vacuum
mu0_emaa 4*pi*1e-7 Hjm Permeability of vacuum
nu_esmga 100 Hz Frequency
Synchronize equivalent variables
[ OK ] [ Cancel ] [ Apply ] [ Help ]

2 The current has a frequency of 100 Hz; enter the value 100 in the corresponding
edit field in the Expression column on the nu_emgqa row. This model uses the default
values of the permittivity and permeability of vacuum, so leave these fields
untouched.

3 Click OK to close the dialog box.

Boundary Conditions

I Open the Boundary Settings dialog box by selecting Boundary Settings from the

Physics menu.

Boundary Settings - Azimuthal Induction Currents, Vector Potential (emga) £
Equation
A‘p =0
Boundaries ‘ Gmups‘ Conditions
Boundary selection Boundary sources and constraints
Boundary condition: | Magnetic insulation -

Group:

[ Select by group

[] Interior boundaries

[ QK ] [ Cancel ] [ Apply ] [ Help ]

2 Enter the boundary conditions according to the following table:

SETTING BOUNDARIES |, 3,5 BOUNDARIES 2,7, 9

Boundary condition Axial symmetry Magnetic insulation
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Note: You can select a boundary either in the Boundary selection list or by clicking on
it in the main drawing area. To select several boundaries simultaneously, use the Shift

and Ctrl keys.

3 Click OK.

Boundaries 1, 3, and 5 make up the vertical boundary along the z-axis, and the axial
symmetry boundary condition makes certain the solution is symmetric around this
axis. The boundary condition at the other three boundaries (2, 7, and 9) sets the
magnetic potential, Aq) , to zero along that boundary.

Subdomain Settings

I From the Physics menu, choose Subdomain Settings. Click the Electric Parameters

tab.

Equation

Subdomain Settings - Azimuthal Induction Currents, Vector Potential (emqga)

- 2. -1 -1 = = =
(jwo - w zuzr)A+ v x(uu ;. V xA)-ov x(V xA)—(D‘\u'lDopIZrlr+J LD)E(D'A_ALDELD

E

Subdomains | Grgupsl

Infinite Elements I

Group:
[ Select by aroup

Active in this domain

Viaop

a

Jo
sigCoil
1

Forces Init | Element I
Subdomain selection Magnetic Parameters | Electric Parameters
1 o Electric materisl properties and current sources
2 Library material: =
Constitutive relation
@ D=5 F D=gE+P O D=zgE+D,
Quantity Value,/Expression Unit Description

v Loop potential

Afmz External current density

S/m  Electric conductivity

Relative permittivity

[

][ Cancel H Apply H

Help

]

2 The domain properties for this model appear in the following table. Use default

values for any properties not supplied.

SETTINGS SUBDOMAIN | SUBDOMAIN 2 SUBDOMAIN 3
o 0 sigCyl sigCoil
e 0 0 Jo
J<|>
3 Click OK.
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MESH GENERATION

In this model, as in many others dealing with electromagnetic phenomena, the effects
on fields near the interfaces between materials are of special interest. To get accurate
results make sure to generate a very fine mesh in these areas. To do so in this case,
refine the mesh one time.

I To generate a mesh, choose Initialize Mesh from the Mesh menu, or use the
corresponding button on the Main toolbar.

2 Choose Refine Mesh from the Mesh menu or use the corresponding button on the
Main toolbar.

3 To better see the mesh in the region of interest, choose Zoom>Zoom Window from
the Options menu. You can now draw a rectangular window around the coil and the

cylinder to get a better view.
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COMPUTING THE SOLUTION

Select Solve Problem from the Solve menu.

POSTPROCESSING AND VISUALIZATION

After solving the problem, the software automatically displays a surface plot for the
dependent variable, in this case, the magnetic vector potential. The buttons on the Plot
toolbar allow you to generate other types of plots.
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To change the default plot parameters follow this procedure:
I Open the Plot Parameters dialog box by choosing Plot Parameters from the
Postprocessing menu.

2 On the General page, select the Surface and Streamline check boxes in the Plot type

area.
3 Click the Surface tab.

4 From the Predefined quantities list on the Surface Data page, sclect Azimuthal

Induction Currents, Vector Potential (emqa)>Total current density, phi component.
5 Click the Streamline tab.

6 From the Predefined quantities list on the Surface Data page, select Magnetic flux
density.

7 Click OK to generate the plot.
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The plot shows the eddy currents induced in the cylinder and the constant current
density in the coil.

Coil With Skin Effect

If the current-carrying coil is homogeneous, you know that a skin effect prevails, and

it is easy to model this effect. In the previous example where the conductivity was zero
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in the coil, you prescribed the current density. Now all you must do is set a conductivity
in the current-carrying coil.

OPTIONS AND SETTINGS

I From the Options menu, choose Constants.

2 Select sigCoil in the variable list and then type 3.7e7 in the corresponding
Expression cdit field.

3 Click OK.

MESH GENERATION

The existing mesh is adequate, so there is no need to generate a new one.

COMPUTING THE SOLUTION

From the Solve menu, select Solve Problem; alternatively click the Solve button on the
Main toolbar.
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The skin effect in the coil is clearly visible.
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